Print
login Счет
Search

При попытке установить пакет обновления Windows XP появляется сообщение об ошибке «Отказано в доступе» или «Установка пакета обновления не завершена»

Проблема

Во время установки пакета обновления 2 (SP2) или пакета обновления 3 (SP3) для Windows XP могут появиться сообщения об ошибках, аналогичные приведенным ниже. Ошибка установки пакета обновления 3 (SP3). Отказано в доступе.Ошибка установки пакета обновления 3 (SP3). Установка пакета обновления не завершена. Также в файле Svcpack.log может содержаться следующее сообщение об ошибке: DoRegistryUpdates failed
Перейти к началу страницы

Причина

Такие ошибки возникают, если ограничения доступа к одному или нескольким разделам реестра не позволяют пакету обновления обновить эти разделы. Ограничения на разделы реестра могут налагаться некоторыми программами, которые изменяют в реестре системные списки управления доступом таким образом, что с помощью учетных записей администратора их не удается изменить. Программа установки пакета обновления запускается с учетной записью администратора (или пользователя) и поэтому не может вносить изменения в разделы реестра, для которых установлены ограничения. Если пакету обновления для Windows XP не удается внести изменения в раздел реестра, на которые наложила ограничения другая программа, установка пакета обновления завершается с ошибкой.

Инструкции по проверке наличия ошибки при внесении изменений в реестр см. в разделе «Дополнительные сведения».
Перейти к началу страницы

Решение

Чтобы устранить эту проблему, воспользуйтесь приведенными ниже способами в указанном порядке. Эти способы предназначены для пользователей со средним и высоким уровнем подготовки.

Примечание. Чтобы воспользоваться этими способами, необходимо войти в систему с учетной записью администратора. Если компьютер является персональным, учетная запись, используемая для входа в систему, наверняка уже имеет права администратора. Если компьютер является рабочим и подключен к сети, возможно, за помощью потребуется обратиться к системному администратору. Чтобы убедиться в том, что вход в Windows выполнен с учетной записью администратора, зайдите на веб-сайт Майкрософт по следующему адресу: http://support.microsoft.com/gp/admin (http://support.microsoft.com/gp/admin)

Перейти к началу страницы

Способ 1. Перезагрузка компьютера с последующей загрузкой и установкой пакета обновления 3 (SP3) для Windows XP с веб-сайта Центра загрузки Майкрософт

Если один из файлов, необходимых программе для работы, заблокирован, перезагрузка компьютера может разблокировать его. Чтобы попытаться разблокировать файл, закройте все программы и перезагрузите компьютер. После этого попробуйте загрузить и установить пакет обновления еще раз.

Если первая попытка установить пакет обновления 3 (SP3) для Windows XP с помощью Центра обновления Windows завершилась с ошибкой, загрузите полную загружаемую версию пакета обновления 3 (SP3) для Windows XP из Центра загрузки Майкрософт. Загрузив пакет обновления, попытайтесь установить его. Дополнительные сведения о загрузке пакета обновления 3 (SP3) для Windows XP см. в следующей статье базы знаний Майкрософт: 322389 (http://support.microsoft.com/kb/322389/ ) Как получить последний пакет обновления для Windows XP
Если этот способ помог избавиться от сообщений об ошибках и успешно установить пакет обновления 3 (SP3) для Windows XP, проблема устранена.

Дополнительные сведения о восстановлении параметров безопасности по умолчанию в Windows XP см. в следующей статье базы знаний Майкрософт: 313222 (http://support.microsoft.com/kb/313222/ ) Восстановление параметров безопасности по умолчанию

Если этот способ не помог устранить проблему, воспользуйтесь способом 2.
Перейти к началу страницы

Способ 2. Перезагрузка компьютера и закрытие или отключение всех запущенных антивирусных или антишпионских программ

Внимание! Выполнение описанных ниже действий повышает степень уязвимости компьютера или сети перед атаками злоумышленников или проникновением вирусов и других вредоносных программ. Корпорация Майкрософт не рекомендует использовать этот метод, но в случае необходимости этот способ можно применить на свой собственный риск. В случае использования данного метода обхода проблемы полагайтесь на свои опыт и знания.

Чтобы снизить риск подвергнуться атаке со стороны злонамеренных пользователей или программного обеспечения, не посещайте другие веб-сайты и не загружайте файлы, пока закрыты или отключены программы для защиты от вирусов и шпионского ПО.

Сбой в ходе установки чаще всего связан с тем, что программа стороннего производителя (например, антивирусная) удерживает открытым или блокирует файл, необходимый для установки пакета обновления. Чтобы избежать этой проблемы, перед установкой пакета обновления 3 для Windows XP выполните указанные ниже действия.

  1. Закройте все программы и перезагрузите компьютер.
  2. После перезагрузки компьютера закройте или отключите все запущенные антивирусные или антишпионские программы.

    Примечание. Эти программы можно отключить в области уведомлений. Для этого щелкните правой кнопкой мыши значок программы стороннего производителя и выберите команду закрытия или отключения приложения. Если такая возможность отсутствует, ознакомьтесь с документацией на программу или обратитесь к ее изготовителю за инструкциями.
  3. Закрыв антивирусную или антишпионскую программу, установите полный пакет обновления 3 (SP3) для Windows XP, который был загружен при выполнении действий, описанных в способе 1.
  4. После установки пакета обновления 3 (SP3) для Windows XP включите антивирусные или антишпионские программы, отключенные при выполнении действия 2.

Если этот способ помог избавиться от сообщений об ошибках и успешно установить пакет обновления 3 (SP3) для Windows XP, проблема устранена.

Если он не помог и вы готовы воспользоваться инструкциями по устранению неполадок для опытных пользователей, обратитесь к разделу «Продвинутые способы устранения неполадок». В противном случае перейдите к разделу «Дальнейшие действия».
Перейти к началу страницы

ПРОДВИНУТЫЕ СПОСОБЫ УСТРАНЕНИЯ НЕПОЛАДОК

В этом разделе предложен продвинутый способ устранения неполадок на случай, если действия, описанные в разделе «Решение», не помогли. Он предназначен только для опытных пользователей.
Перейти к началу страницы

Способ 1. Сброс параметров разрешений на доступ к реестру и файлам

Важно! В данный раздел, описание метода или задачи включены сведения об изменении параметров реестра. Однако их неправильное изменение может привести к возникновению серьезных проблем. Поэтому при выполнении таких действий строго соблюдайте инструкции. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра. При возникновении неполадок реестр можно восстановить. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт: 322756 (http://support.microsoft.com/kb/322756/ ) Создание резервной копии, редактирование и восстановление реестра Windows XP и Windows Server 2003
Чтобы сбросить разрешения на доступ к реестру и файлам, выполните описанные ниже действия.

  1. Загрузите и установите файл Subinacl.exe. Для этого посетите веб-узел корпорации Майкрософт по адресу: http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en)
  2. Запустите Блокнот.
  3. Скопируйте указанный ниже текст и вставьте его в блокнот. cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

    Корпорация Майкрософт предоставляет примеры программного кода только для иллюстрации и не предоставляет явных или подразумеваемых гарантий относительно их пригодности для применения в тех или иных целях. Примеры в данной статье рассчитаны на пользователя, имеющего достаточный уровень знаний соответствующего языка программирования и необходимых средств разработки и отладки. Сотрудники службы поддержки Майкрософт могут объяснить работу конкретной процедуры, но не будут изменять примеры для реализации дополнительных возможностей или удовлетворения требований конкретных пользователей.
  4. Сохраните этот файл под именем Reset.cmd.
  5. Дважды щелкните файл Reset.cmd, чтобы выполнить сценарий.

    Примечание. Выполнение этого файла сценария может занять длительное время. Его необходимо выполнять от имени администратора.
  6. Установите пакет обновления 3 (SP3) для Windows XP.

Если этот способ помог избавиться от сообщений об ошибках и успешно установить пакет обновления 3 (SP3) для Windows XP, проблема устранена.

Если этот способ не помог устранить проблему, перейдите к разделу «Дальнейшие действия».
Перейти к началу страницы

Дополнительная информация

Проверка наличия сбоя при внесении изменений в реестр

  1. Выберите в меню Пуск пункт Выполнить, введите %windir%\svcpack.log и нажмите кнопку ОК. Откроется файл Svcpack.log.
  2. В меню Правка выберите команду Найти.
  3. В поле Что введите DoRegistryUpdates failed и нажмите кнопку Найти далее.

    Если при попытке внести изменения в реестр произошел сбой, в файле журнала появится сообщение об ошибке с текстом «DoRegistryUpdates failed». Такое сообщение говорит о наличии проблемы, не позволяющей вносить изменения в реестр. Оно выглядит примерно так: xxxx.xxx: DoInstallation:DoRegistryUpdates failed.
    xxxx.xxx: Access is denied.
    xxxx.xxx: Сообщение, выводимое на экран: Access is denied. Примечание. В этом сообщении xxxx.xxx представляет собой отметку времени каждой записи.


Перейти к началу страницы

Антивирусная программа

Антивирусное программное обеспечение предназначено для защиты компьютера от вирусов. Если антивирусная программа отключена, не следует загружать или открывать файлы из ненадежных источников, посещать веб-сайты, в безопасности которых имеются сомнения, или открывать вложения электронной почты. Дополнительные сведения о компьютерных вирусах см. в следующей статье базы знаний Майкрософт: 129972 (http://support.microsoft.com/kb/129972/ ) Компьютерные вирусы - описание, меры безопасности и удаление

Перейти к началу страницы

ДАЛЬНЕЙШИЕ ДЕЙСТВИЯ

Если с помощью описанных способов проблему устранить не удалось, можно перейти на веб-сайт службы технической поддержки Майкрософт и попытаться найти другие способы устранения проблемы. Ниже перечислены некоторые услуги, которые можно найти на веб-сайте службы технической поддержки Майкрософт.

Если проблема по-прежнему не устранена, можно обратиться в службу поддержки по следующему адресу: http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

Перейти к началу страницы

Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Service Pack 3
  • Microsoft Windows XP Service Pack 2


Перейти к началу страницы



Код статьи:
949377

Последнее изменение:
5 января 2011 г. - Редакция: 4.0