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FIX: The Explorer.exe process stops responding (hangs) when you use Windows Explorer that hosts a shell extension that was created by using MFC

SYMPTOMS

You have a Windows Explorer shell extension that is developed by the Microsoft Foundation Class library (MFC). The shell extension is hosted in Windows Explorer. However, the Explorer.exe process stops responding (hangs) when you open Windows Explorer.
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CAUSE

This problem occurs because of a code defect in MFC.
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RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To download this hotfix from the MSDN Code Gallery, visit the following Microsoft Web site: http://code.msdn.microsoft.com/KB972685 (http://code.msdn.microsoft.com/KB972685) Note An ATL security update has since been released, and we highly recommend installing this ATL security update instead: http://support.microsoft.com/?kbid=973552 (http://support.microsoft.com/?kbid=973552) Update 973552 fixes the issues that are described in Microsoft Knowledge Base article 972685 (this knowledge base article) and in Microsoft Knowledge Base article 973552. To download the update, visit the following Microsoft Web site: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=2051a0c1-c9b5-4b0a-a8f5-770a549fd78c (http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=2051a0c1-c9b5-4b0a-a8f5-770a549fd78c) Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language listed, it is because the Code Gallery resource page is not available for that language.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Prerequisites

There are no prerequisites for installing this update.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this table Expand this table

File nameFile versionFile sizeDateTimePlatform
Vcredist_x64.exe 9.0.30729.4048 5,241,184 15-Jul-2009 06:49 x86
Vcredist_x86.exe 9.0.30729.4048 4,495,200 15-Jul-2009 06:49 x86


Note For x86-based versions of Windows, select the packages ending with "_x86." For x64-based versions of Windows, select the packages ending with "_x64" for 64-bit applications and the packages ending with "_x86" for 32-bit applications.

If you experience the problem on a computer that has installed Visual Studio 2008, apply the hotfix that is described in KB 958314. For more information, click the following article number to view the article in the Microsoft Knowledge Base: 958314 (http://support.microsoft.com/kb/958314/ ) FIX: The Explorer.exe process becomes unresponsive when Windows Explorer hosts a shell extension which is developed by MFC library
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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
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MORE INFORMATION

This problem exists in the following MFC modules whose versions are in the range between 9.0.30304.0 and 9.0.30729.176.

  • MFC90.dll
  • MFC90u.dll
  • MFC90d.dll
  • MFC90ud.dll


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APPLIES TO
  • Microsoft Windows 2000 Service Pack 4
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Standard without Hyper-V
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate


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Article ID:
972685

Last Review:
February 22, 2010 - Revision: 4.2



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Alias ID : 972685
Document ID : HT070694
Legacy Document ID : 1261110914140272
Last Updated :
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