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You cannot install updates from Windows Update, Microsoft Update, or by using Automatic Update after a repair install of Windows XP or after you install Windows XP SP3 immediately after a clean install of Windows XP SP2

SYMPTOMS

When you try to install Windows updates from the Windows Update Web site, the Microsoft Update Web site, or by using Automatic Update, you receive a message that the update is not installed successfully. Additionally, the update is not displayed in the update history.

You may experience this issue in the following scenarios:

Scenario 1

You try to install updates after repair a Windows XP installation by using the Windows XP CD.

Scenario 2

You perform the following operations before you try to install Windows updates:

  1. You perform a new installation of Windows XP Service Pack 2 (SP2).
  2. You visit the Windows Update Web site, or the Microsoft Update Web site.

    Note When you visit the update Web site, the latest version of Windows Update software will be installed in your computer.
  3. You install Windows XP Service Pack (SP3) without a restart.
  4. You try to install Windows updates after the install of Windows XP SP3.

If you are experiencing other Windows Update related issues, see the "More Information" section to find appropriate solutions.
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CAUSE

This issue occurs because the Wups2.dll file that is included in the latest version of Windows Update is not installed correctly.

For scenario 1, the registry entries that correspond to the Wups2.dll file are missing after the repair install of Windows XP. The release version of Windows XP does not contain the Windows Update software.

For scenario 2, the registry entries that correspond to Windows Update are changed back to the Windows XP SP2 version if you did not restart the computer before you install Windows XP SP3. The registry entries for the Wups2.dll file are changed to pointing to the Wups.dll file that is included in the release version of Windows XP SP2.
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RESOLUTION

To resolve this problem, use one of the following methods.
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Method 1: Download and install the Windows Update Agent

Click here to view or hide how to determine whether you are running a 32-bit or a 64-bit edition of Windows

To learn whether it is a 32-bit version or 64-bit version, open System Information (Msinfo32.exe). Then, review the value that is listed for System Type. To do this, follow these steps:

  1. Click Start, and then click Run.
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  2. Type msinfo32.exe, and then click OK or press ENTER.
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  3. In System Information, review the value for System Type.
    • For 32-bit editions of Windows, the System Type value is x86-based PC.
    • For 64-bit editions of Windows, the System Type value is x64-based PC.
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The following files are available for download from the Microsoft Download Center:

For an x86-based computer
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Download Download the windowsupdateagent30-x86.exe package now. For an x64-based computer
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Download Download the windowsupdateagent30-x64.exe package now. For an Itanium-based computer
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Download Download the windowsupdateagent30-ia64.exe package now.
For more information about how to download the latest version of Windows Update Agent, click the following article number to view the article in the Microsoft Knowledge Base: 949104 How to obtain the latest version of the Windows Update Agent to help manage updates on a computer

Was this information helpful? Please send us your feedback
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Method 2: Register the Wups2.dll file

To have us register the Wups2.dll file in Windows for you, go to the " Fix it for me " section. If you prefer to fix this problem yourself, go to the " Let me fix it myself " section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Click Run in the File Download dialog box, and follow the steps in the Fix it wizard.

Fix this problem
Microsoft Fix it 50597


Notes

  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.


Then, go to the " Did this fix the problem? " section.

Let me fix it myself

Click here to view or hide how to register the Wups2.dll file
To register the Wups2.dll file in Windows, follow these steps:

  1. Stop the Automatic Updates service. To do this, follow these steps:
    1. Open the Command Prompt window. To do this, click Start, click Run, type cmd, and then click OK.
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    2. At the command prompt, type the following command, and then press ENTER: net stop wuauserv
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  2. Register the Wups2.dll file. To do this, follow these steps:
    1. At the command prompt, type the following command, and then press ENTER: regsvr32 %windir%\system32\wups2.dll

      Note For a computer that is running Windows XP Professional x64 Edition, type the following command, and then press ENTER: regsvr32 %windir%\syswow64\wups2.dll
    2. Click OK if you receive a verification message.
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  3. Start the Automatic Updates service. To do this, type the following command at the command prompt, and then press ENTER: net start wuauserv
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  4. Exit the Command Prompt window. To do this, type exit at the command prompt, and then press ENTER.
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Was this information helpful? Please send us your feedback

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the " Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) .


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MORE INFORMATION

Other Microsoft Knowledge Base articles that may help you resolve your Windows Update problem:

Click here to view or hide detailed information
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base: 933528 (http://support.microsoft.com/kb/933528/ ) Error message when you try to install Microsoft Update on a Windows Vista-based computer: "Could not install Microsoft Update on the computer. 0x80004005"
958051 (http://support.microsoft.com/kb/958051/ ) You may receive a "0x8007F0F4" error code when you try to install updates from the Windows Update Web site or from the Microsoft Update Web site
836941 (http://support.microsoft.com/kb/836941/ ) You may encounter temporary connection-related errors when you use Windows Update or Microsoft Update to install updates
946414 (http://support.microsoft.com/kb/946414/ ) Error when you download updates using Windows Update or Microsoft Update: 8000FFFF
910336 (http://support.microsoft.com/kb/910336/ ) You receive a "0x80070002" or "0x80070003" error code after you download an update from Windows Update, from Microsoft Update, or from Windows Server Update Services
929458 (http://support.microsoft.com/kb/929458/ ) Error code 0x80072F8F when you try to search for available updates on Windows Update and Microsoft Update sites
900936 (http://support.microsoft.com/kb/900936/ ) Error code 0x8024402C when you try to install updates on Windows Update or Microsoft Update Web sites
958049 (http://support.microsoft.com/kb/958049/ ) Error code when you use the Windows Update or Microsoft Update Web site to install updates: "0x8007066A"
919749 (http://support.microsoft.com/kb/919749/ ) Error code 0x80245003 when you try to install updates from the Windows Update Web site or the Microsoft Update Web site
958052 (http://support.microsoft.com/kb/958052/ ) You receive error code 0x80070643 or error code 0x643 when you use the Windows Update or Microsoft Update Web sites to install updates
910337 (http://support.microsoft.com/kb/910337/ ) You may receive an error message that contains the "0x8DDD0018" code or the "0x80246008" code when you try to download updates from the Microsoft Windows Update Web site or from the Microsoft Update Web site

For more information about how to troubleshoot Windows Update issues, click the following article numbers to view the articles in the Microsoft Knowledge Base:

Click here to view or hide detailed information
910339 (http://support.microsoft.com/kb/910339/ ) How to troubleshoot Windows Update or Microsoft Update when you are repeatedly offered an update
906602 (http://support.microsoft.com/kb/906602/ ) How to troubleshoot common Windows Update, Microsoft Update, and Windows Server Update Services installation issues
306525 (http://support.microsoft.com/kb/306525/ ) How to configure and use Automatic Updates in Windows XP
950718 (http://support.microsoft.com/kb/950718/ ) How to troubleshoot an unsuccessful installation of Windows XP Service Pack 3

Click the following links to find more options if this article cannot resolve your problem:


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APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Home Edition, when used with:
    • Microsoft Windows XP Service Pack 2
    • Microsoft Windows XP Service Pack 3
  • Microsoft Windows XP Media Center Edition 2004
  • Microsoft Windows XP Media Center Edition 2005
  • Microsoft Windows XP Tablet PC Edition


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Article ID:
943144

Last Review:
January 28, 2011 - Revision: 10.0



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Alias ID : 943144
Document ID : HT070277
Legacy Document ID : 1261110914140348
Last Updated :
Copyright © Lenovo 2013, all rights reserved
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